Kinesis Platform - Performance degradation

Incident Report for Kinesis

Resolved

This incident has been resolved.
Posted May 07, 2026 - 22:05 UTC

Identified

The issue is related to an issue with a database index, this is being rebuilt and will take approximately 30 minutes to return to normal operation.
Posted May 07, 2026 - 21:42 UTC

Investigating

There is a severe slow-down in the system, causing some pages to return no data.
Posted May 07, 2026 - 21:41 UTC